IOS vs XR: Pseudowire/xconnect

Scenario

R1 and R3 are PE routers. R2 is a P router. A pseduowire (aka xconnect) is configured between R1 and R3 with VCID 100. The R1 interface assigned to the pseudowire is Gi0/0/0/0.10. IS-IS is configured to advertise the loopbacks used for the xconnects (connected subnets are advertised too but not needed). The relevant config for R1 is shown.

IOS-vs-XR_xconnect

IOS Config

hostname R1
!
pseudowire-class CLASS_ONE
 encapsulation mpls
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0.10
 description Pseudowire Subinterface
 encapsulation dot1Q 10
 xconnect 3.3.3.3 100 pw-class CLASS_ONE
!
interface GigabitEthernet0/0/0/1
 description link to R2
 ip address 10.1.2.1 255.255.255.252
 ip router isis LAB
 mpls ip
 isis circuit-type level-2-only
 isis network point-to-point 
 isis csnp-interval 10
!
router isis LAB
 net 49.0500.0000.0000.0002.00
 is-type level-2-only
 passive-interface Loopback0
!

XR Config

hostname R1
!
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0.10
 encapsulation dot1q 10
!
interface GigabitEthernet0/0/0/1
 description link to R2
 ipv4 address 10.1.2.1 255.255.255.252
!
router isis LAB
 is-type level-2-only
 net 49.0500.0000.0000.0002.00
 address-family ipv4 unicast
  !
  interface Loopback0
   passive
   address-family ipv4 unicast
   !
  !
  interface GigabitEthernet0/0/0/1
   circuit-type level-2-only
   point-to-point
   address-family ipv4 unicast
  !
 !
!
l2vpn
 xconnect group XCONNECT-GROUP-ONE
  p2p XCONNECT
   interface GigabitEthernet0/0/0/0.10
   neighbor ipv4 3.3.3.3 pw-id 100
   !
  !
 !
!
mpls ldp
 router-id 1.1.1.1
 interface GigabitEthernet0/0/0/1
 !
!

Back to top