IOS vs XR: Carrier Supporting Carrier

Scenario
This comparison shows how Carrier Supporting Carrier is configured from the point of view of BB-PE2, an edge router for the backbone provider. OSPF + LDP is the internal configuration for the Backbone Provider. BGP-LU is configured between BB-PE2 and ASBR2.

This is best viewed alongside this CsC cheatsheet or this GNS3 lab.

There is an alternate approach to CsC, using IGP+LDP between the Backbone Provider and the Customer Provider Edge Routers, but IOS-XR does not support VRF aware LDP. This means that in such as setup, an IOS-XR cannot play the role of the Backbone Edge Router.  

IOS-vs-XR_CsC

IOS Config

hostname BB-PE2
!
ip cef
!
ip vrf CSC_CUST_ISP1
 rd 100:500
 route-target export 100:500
 route-target import 100:500
!
!
!
interface Loopback0
 ip address 100.2.2.2 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet0/1
 description link to ASBR2
 ip vrf forwarding CSC_CUST_ISP1
 ip address 192.168.117.6 255.255.255.252
!
interface GigabitEthernet0/0
 description link to BB-Core
 ip address 10.30.23.2 255.255.255.0
 ip ospf 1 area 0
!
router ospf 1
 mpls ldp autoconfig
 router-id 100.2.2.2
 log-adjacency-changes
 passive-interface Loopback0
!
router bgp 100
 bgp router-id 100.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 100.1.1.1 remote-as 100
 neighbor 100.1.1.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 100.1.1.1 activate
  neighbor 100.1.1.1 send-community extended
  neighbor 100.1.1.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf CSC_CUST_ISP1
  neighbor 192.168.117.5 remote-as 500
  neighbor 192.168.117.5 activate
  neighbor 192.168.117.5 send-label
  no synchronization
 exit-address-family
!

XR Config

hostname BB-PE2
!
vrf CSC_CUST_ISP1
 address-family ipv4 unicast
  import route-target
   100:500
  !
  export route-target
   100:500
  !
 !
!
interface Loopback0
 ipv4 address 100.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/1
 description link to ASBR2
 vrf CSC_CUST_ISP1
 ipv4 address 192.168.117.6 255.255.255.252
!
interface GigabitEthernet0/0/0/0
 description link to BB-Core
 ipv4 address 10.30.23.2 255.255.255.0
!
route-policy PASS
  pass
end-policy
!
! XR devices cannot label switch to a next-hop
! that is not learned via a /32 host. Hence the
! need for a static route here.
router static
 vrf CSC_CUST_ISP1
  address-family ipv4 unicast
   192.168.117.5/32 GigabitEthernet0/0/0/1
  !
 !
!
router ospf 1
 log adjacency changes
 address-family ipv4 unicast
 area 0
  mpls ldp auto-config
  interface Loopback0
   passive enable
  !
  interface GigabitEthernet0/0/0/0
  !
 !
!
router bgp 100
 bgp router-id 100.2.2.2
 bgp log neighbor changes detail
 address-family vpnv4 unicast
 !
 neighbor 100.1.1.1
  remote-as 100
  update-source Loopback0
  address-family vpnv4 unicast
   next-hop-self
  !
 !
 vrf CSC_CUST_ISP1
  rd 100:500
  ! Note the need to specify allocate-label all on XR under
  ! the bgp vrf config
  address-family ipv4 unicast
   allocate-label all
  !
  neighbor 192.168.117.5
   remote-as 500
   address-family ipv4 labeled-unicast
    route-policy PASS in
    route-policy PASS out
   !
  !
 !
!
! Remember to enable LDP globally
mpls ldp
 address-family ipv4
 !
!

Back to top