IOS vs XR: Pim Sparse Mode with Static RP

Scenario
Basic PIM-SM Setup with static RP. One LAN and one WAN interface.

IOS Config

ip multicast-routing
!
interface FastEthernet0/0
 description link PC LAN
 ip address 10.11.2.25 255.255.255.0
 ip pim sparse-mode
 ip cgmp
 ip ospf 1 area 0
 speed 100
 full-duplex 
!
interface Serial0/1
 description link to R2
 ip address 10.12.5.1 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
 clock rate 2000000
!
ip pim rp-address 10.224.1.1

XR Config

interface GigabitEthernet0/0/0/0
 description link to PC LAN
 ipv4 address 10.11.2.25 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 description link to R2
 ipv4 address 10.12.5.1 255.255.255.0
 speed 100
 duplex full
!
!
multicast-routing
 address-family ipv4
 interface all enable
 !
!
router igmp
 interface GigabitEthernet0/0/0/0
 !
 version 2
!
router pim
 address-family ipv4
 rp-address 10.224.1.1
 interface GigabitEthernet0/0/0/0
 enable
 !
 interface GigabitEthernet0/0/0/1
 enable
 !
 !
!

Back to top