IOS vs XR: Traffic Engineering

Scenario
This shows a simple MPLS TE setup between two PEs from the perspective of PE1. An MPLS TE tunnel, Tunnel1, is built between PE1 and PE2 with the following characteristics:

  • An explicit path has been configured to follow the lower P1-P2-P3 path
  • A dynamic path is to be used as a second option
  • The setup priority is 2 and the hold priority is 1
  • The tunnel uses autoroute announce with a relative metric of -5
  • The tunnel is signalling to use 10Mbps of bandwidth
  • The tunnel uses the default of the TE metrics to decide the dynamic path, but the link to P1 has been given an administrative weight of 100.
  • Re-optimization will take place when there is a link flap
  • Each interface has been configured with a maximum reservable bandwidth of 80Mbps

IOS-vs-XR_TE

IOS Config

hostname PE1
!
mpls traffic-eng tunnels
mpls traffic-eng reoptimize events link-up
!
interface Loopback0
 ip address 100.100.100.100 255.255.255.255
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 200.200.200.200
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 2 1
 tunnel mpls traffic-eng autoroute metric relative -5
 tunnel mpls traffic-eng bandwidth 10000
 tunnel mpls traffic-eng path-option 1 explicit name PATH1
 tunnel mpls traffic-eng path-option 2
!
interface GigabitEthernet0/0
 description link to P1
 ip address 10.10.101.10 255.255.255.0
 ip router isis CORE
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng administrative-weight 100
 isis circuit-type level-2-only
 isis network point-to-point
 ip rsvp bandwidth 80000
!
interface GigabitEthernet0/1
 description link to P4
 ip address 10.10.104.10 255.255.255.0
 ip router isis CORE
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 isis network point-to-point
 ip rsvp bandwidth 80000
!
router isis LAB
 net 49.0500.0100.0100.0100.00
 is-type level-2-only
 metric-style wide
 passive-interface Loopback0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
!
ip explicit-path name PATH1 enable
 index 1 next-address 10.10.101.1
 index 2 next-address 10.10.12.2
 index 3 next-address 10.10.23.3
 index 4 next-address 10.10.203.20

XR Config

hostname PE1
!
explicit-path name PATH1
 index 1 next-address strict ipv4 unicast 10.10.101.1
 index 2 next-address strict ipv4 unicast 10.10.12.2
 index 3 next-address strict ipv4 unicast 10.10.23.3
 index 4 next-address strict ipv4 unicast 10.10.203.20
!
interface Loopback0
 ipv4 address 100.100.100.100 255.255.255.255
!
interface tunnel-te1
 ipv4 unnumbered Loopback0
 priority 2 1
 signalled-bandwidth 10000
 autoroute announce
  metric relative -5
 !
 destination 200.200.200.200
 path-option 1 explicit name PATH1
 path-option 2 dynamic
 
!
interface GigabitEthernet0/0/0/0
 description link to P1
 ipv4 address 10.10.101.10 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 description link to P4
 ipv4 address 10.10.104.10 255.255.255.0
!
router isis CORE
 is-type level-2-only
 net 49.0500.0100.0100.0100.00
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only
  mpls traffic-eng router-id Loopback0
 !
 interface Loopback0
  passive
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
  !
 !
rsvp
 interface GigabitEthernet0/0/0/0
  bandwidth 80000
 !
 interface GigabitEthernet0/0/0/1
  bandwidth 80000
 ! 
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
  admin-weight 100
 !
 interface GigabitEthernet0/0/0/1
 !
 reoptimize events link-up
!
mpls ldp
 address-family ipv4
 !
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
!

Back to top