Inter-AS Option B

Scenario
This comparison shows an MPLS Inter-AS Option B setup as follows:

This setup shows both the ASBR1s configuration with the following conditions:

  • An iBGP VPNv4 multi-hop session to local the route-reflectors, setting next-hop to self.
  • An eBGP VPNv4 multi-hop session between the ASBRs
  • Routes with RTs that are no imported on locally configured VRFs are retained
  • MPLS forwarding over BGP is configured.

For more information on how Inter-AS options work, including Option B with BGP, see this document.

IOS Config

hosthostname ASBR2
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet1
 description Inter-AS Link to ISP2
 ip address 192.168.117.1 255.255.255.252
 mpls bgp forwarding
!
interface GigabitEthernet2
 description link to P2
 ip address 10.20.24.2 255.255.255.0
 ip router isis LAB
 mpls ip
 isis circuit-type level-2-only
!
router isis LAB
 net 49.0500.2222.2222.2222.00
 is-type level-2-only
 metric-style wide
 passive-interface Loopback0
!
router bgp 500
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 no bgp default route-target filter
 neighbor 3.3.3.3 remote-as 500
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 192.168.117.2 remote-as 600
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
  neighbor 3.3.3.3 next-hop-self
  neighbor 192.168.117.2 activate
  neighbor 192.168.117.2 send-community extended
 exit-address-family
!

XR Config

hostname ASBR1
logging console debugging
!
interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0/1
 description link to ASBR2
 ipv4 address 192.168.117.1 255.255.255.252
!
interface GigabitEthernet0/0/0/2
 description link to P1
 ipv4 address 10.10.24.2 255.255.255.0
!
route-policy PASS
  pass
end-policy
!
router static
 address-family ipv4 unicast
  192.168.117.2/32 GigabitEthernet0/0/0/1
 !
!
router isis CORE
 is-type level-2-only
 net 49.0500.2222.2222.2222.00
 address-family ipv4 unicast
 !
 interface Loopback0
  passive
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  address-family ipv4 unicast
  !
 !
!
router bgp 500
 bgp router-id 2.2.2.2
 bgp log neighbor changes detail
 address-family ipv4 unicast
 !
 address-family vpnv4 unicast
  retain route-target all
 !
 neighbor 3.3.3.3
  remote-as 500
  update-source Loopback0
  address-family vpnv4 unicast
   next-hop-self
  !
 !
 neighbor 192.168.117.2
  remote-as 600
  address-family vpnv4 unicast
   route-policy PASS in
   route-policy PASS out
  !
 !
!
mpls ldp
 router-id 2.2.2.2
 address-family ipv4
  label
   local
    allocate for host-routes
   !
  !
 !
 interface GigabitEthernet0/0/0/2
 !
!

Back to top