IOS vs XR: OSPF Virtual-Link

Scenario
Area 3 is seperated from the backbone each. The below config shows the configuration from the point of view of R1

IOS-vs-XR_OSPF_VIRTUAL_LINK

IOS Config

hostname R1
!
interface FastEthernet0/0
 description link to R4
 ip address 192.168.14.1 255.255.255.252
 ip ospf 1 area 0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description link to R2
 ip address 172.16.12.1 255.255.255.252
 ip ospf 1 area 2
 speed 100
 full-duplex
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 area 2 virtual-link 3.3.3.3
!

XR Config

hostname R1
!
interface GigabitEthernet0/0/0/0
 description link to R4
 ipv4 address 172.16.14.1 255.255.255.252
 speed 100
 duplex full
!
interface GigabitEthernet0/0/0/1
 ipv4 address 172.16.12.1 255.255.255.252
 speed 100
 duplex full
!
router ospf 1
 router-id 1.1.1.1
 address-family ipv4 unicast
 area 0
  interface GigabitEthernet0/0/0/0
 !
 !
 area 2
  virtual-link 3.3.3.3
 !
 interface GigabitEthernet0/0/0/1
 !
!

Back to top