IOS vs XR: HSRP

Scenario
Active and Standby Router with simple tracking of WAN interface

IOS Config

R1
---
interface GigabitEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 standby version 2
 standby 101 ip 192.168.1.1
 standby 101 priority 200
 standby 101 preempt
 standby 101 name TEST_HSRP
 standby 101 track 123 decrement 120
! 
track 123 ip sla 1 reachability
! 
ip sla 1
 icmp-echo 192.168.0.2 source-ip 192.168.0.1
 frequency 10
ip sla schedule 1 life forever start-time now

R2
---
interface GigabitEthernet0/0
 ip address 192.168.1.3 255.255.255.0
 standby version 2
 standby 101 ip 192.168.1.1
 standby 101 priority 90
 standby 101 preempt
 standby 101 name TEST_HSRP

XR Config

R1
---
router hsrp
 interface GigabitEthernet0/0/0/0
  address-family ipv4
   hsrp 101 version 2
    name TEST_HSRP
    preempt
    priority 200
    address 192.168.1.1
    track object TRACK_A_END 120
    !
   !
  !
 !
! 
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.1.2
! 
ipsla
 operation 1
  type icmp echo
   source address 192.168.0.1
   destination address 192.168.0.2
   !
  !
 !
!
schedule operation 1
 start-time now
 life forever
 !
!
track TRACK_A_END
 type rtr 1 reachability
!

R2
---
router hsrp
 interface GigabitEthernet0/0/0/0
  address-family ipv4
   hsrp 101 version 2
    name TEST_HSRP
    preempt
    priority 90
    address 192.168.1.1
    !
   !
  !
 !
! 
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.1.3
!

Back to top