Segment Routing

Scenario
All devices in this topology are configured to run SR with no LDP, with the exception of R5, which is LDP-only. This comparison looks at R4, which is configured to run SR and act as a mapping server so that those nodes that do not run LDP know what LFIB entry to install when forwarding traffic to R5’s loopback. This also highlights a key different between IOS-XE and IOS-XR Segment Routing capabilities in that IOS-XE does not support the configuration or forwarding of IPv6 Node-SIDs.

IOS Config

hostname R4
!
segment-routing mpls
 !
 set-attributes
  address-family ipv4
   sr-label-preferred
  exit-address-family
 !
 global-block 16000 17999
 !
 connected-prefix-sid-map
  address-family ipv4
   10.1.1.4/32 index 4 range 1
  exit-address-family
!
 mapping-server
  !
  prefix-sid-map
   address-family ipv4
    10.1.1.5/32 index 5 range 1
   exit-address-family
  !
 !
!
interface Loopback5
 ip address 10.1.1.4 255.255.255.255
 ipv6 address 2001:1ab::4/128/128
!
interface GigabitEthernet1
 description link to P7
 ip address 10.4.7.4 255.255.255.0
 ip router isis LAB
 ipv6 address 2001:1ab:4:7::4/64
 ipv6 enable
 ipv6 router isis LAB
 mpls traffic-eng tunnels
 isis network point-to-point  
!
router isis LAB
 net 49.0100.1111.1111.0004.00
 is-type level-2-only
 advertise passive-only
 metric-style wide
 log-adjacency-changes all
 segment-routing mpls
 segment-routing prefix-sid-map advertise-local
 passive-interface Loopback5
 !
 address-family ipv6
  multi-topology
  advertise passive-only
 exit-address-family
 mpls traffic-eng router-id Loopback5
 mpls traffic-eng level-2
!

XR Config

hostname R4
!
interface Loopback0
 ipv4 address 10.1.1.4 255.255.255.255
 ipv6 address 2001:1ab::4/128
!
interface GigabitEthernet0/0/0/0
 description link to R7
 ipv4 address 10.4.7.4 255.255.255.0
 ipv6 address 2001:1ab:4:7::4/64
!
!
router isis LAB
 is-type level-2-only
 net 49.0100.1111.1111.0004.00
 log adjacency changes
 address-family ipv4 unicast
  metric-style wide
  advertise passive-only
  segment-routing mpls sr-prefer
  segment-routing prefix-sid-map advertise-local
  mpls ldp auto-config
 !
 address-family ipv6 unicast
  metric-style wide
  advertise passive-only
  segment-routing mpls sr-prefer
  segment-routing prefix-sid-map advertise-local
 !
 interface Loopback0
  passive
  address-family ipv4 unicast
   prefix-sid absolute 17004
  !
  address-family ipv6 unicast
   prefix-sid absolute 17604
  !
 !
 interface GigabitEthernet0/0/0/0
  point-to-point
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
!
segment-routing
 global-block 17000 23999
 mapping-server
  prefix-sid-map
   address-family ipv4
    10.1.1.5/32 5 range 1
   !
   address-family ipv6
    2001:1ab::5/128 605 range 1
   !
  !
 !
!

Back to top

%d bloggers like this: