IOS vs XR: EIGRP

Scenario
EIGRP uses variance for load-balancing and distribute-lists (IOS) and route-policies (XR) for filtering. This section covers a simple setup with an EIGRP configured router filtering a couple of  /30 transit links and with variance configured for load-balancing.

IOS Config

hostname R1
!
router eigrp 10
 variance 2
 network 10.10.12.0 0.0.0.3
 network 10.10.42.0 0.0.0.3
 network 192.168.50.0
 passive interface GigabitEthernet1/0
 distribute-list prefix BLOCK_TRANSIT_LINKS in
 no auto-summary
 eigrp router-id 2.2.2.2
!
ip prefix-list BLOCK_TRANSIT_LINKS seq 5 deny 10.10.13.0/30
ip prefix-list BLOCK_TRANSIT_LINKS seq 10 deny 10.10.43.0/30
ip prefix-list BLOCK_TRANSIT_LINKS seq 50 permit 0.0.0.0/0 le 32
!
interface GigabitEthernet0/0
 description link to R2
 ip address 10.10.12.2 255.255.255.252
 speed 100
 full-duplex
!
interface GigabitEthernet0/1
 description link to R4
 ip address 10.10.42.2 255.255.255.252
 speed 100
 full-duplex
! 
interface GigabitEthernet0/2
 description Local LAN
 ip address 192.168.50.1 255.255.255.0
 speed 100
 full-duplex

XR Config

hostname R1
!
interface GigabitEthernet0/0/0/0
 description link to R2
 ipv4 address 10.10.12.2 255.255.255.252
 speed 100
 duplex full
!
interface GigabitEthernet0/0/0/1
 description link to R4
 ipv4 address 10.10.42.2 255.255.255.252
 speed 100
 duplex full
!
interface GigabitEthernet0/0/0/2
 description Local LAN
 ipv4 address 192.168.50.1 255.255.255.0
 speed 100
 duplex full
!
prefix-set BLOCK_TRANSIT_LINKS
 10.10.13.0/30,
 10.10.43.0/30
end-set
!
route-policy TRANSIT_FILTER
 if destination in BLOCK_TRANSIT_LINKS then
  drop
 else
  pass
 endif
end-policy
!
router eigrp 10
 address-family ipv4
  router-id 2.2.2.2
  variance 2
  route-policy TRANSIT_FILTER in
  !
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/1
  !
  interface GigabitEthernet0/0/0/2
   passive-interface
  !
 !
!

Back to top