IOS vs XR: PIM Sparse Mode with BSR

Scenario
Basic PIM-SM Setup using BSR to determine the RPs. An access list has been applied it limit the mutlicast groups for which the router can be the RP and the riority and hash mask length have been set. The IP configuration of the interfaces have been left out.

IOS Config

ip multicast-routing
!
interface Loopback0
 ip address 9.9.9.9 255.255.255.255
 ip pim sparse-mode
 description Loopback for RP
!
interface Gi0/0
 
 ip pim sparse-mode
!
interface Gi0/1
 
 ip pim sparse-mode
!
ip pim bsr-candidate Loopback0 30 200
ip pim rp-candidate Loopback0 group-list RESTRICT_RP priority 50
!
ip access-list standard RESTRICT_RP
 permit 228.3.3.9

XR Config

interface Loopback0
 ipv4 address 9.9.9.9 255.255.255.255
 description Loopback for RP
!
multicast-routing
 address-family ipv4
 interface all enable
 !
!
router pim
 address-family ipv4
 interface GigabitEthernet0/0/0/0
 enable
 !
 interface GigabitEthernet0/0/0/1
 enable
 !
 bsr candidate-bsr 9.9.9.9 hash-mask-len 30 priority 200
 bsr candidate-rp 9.9.9.9 group-list RESTRICT_RP priority 50
 !
! 
ipv4 access-list RESTRICT_RP
 10 permit ipv4 host 228.3.3.9 any

Back to top